Converting map from Continent to Kingdom – lines problem

Home Forums Worldographer Converting map from Continent to Kingdom – lines problem

Tagged: 

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #9683
    Anonymous
    Inactive

    After converting map from hexographer and creating kingdom level for continent level map – all lines on kingdom level are crazy – they get width 300 – 400 pixels (on continent level they has 20 px).

    Is there fast way to fix this behavior.

    and another question about lines – in hexographer we had ability to change style of line in configure menu and all lines on map would change their outlook.

    I not find such function in Worldgrapher/ Maybe I am wrong?

    #9697
    Joe
    Keymaster

    I’ve seen others report this problem and I think we put out a fix for it a couple weeks ago. Are you on version 1.156 or 1.157? I believe the fix was in 1.156. (You’ll see the version number in the title bar.

    That said, the lines are supposed to scale to match how you’re set your map to scale. So if your kingdom map has 15 hexes across for every hex in the continent level and at the continent level they are 20% of a hex, they should be 300% of a hex (basically spanning 3 hexes.

    A couple of screenshots may help too if you can share them.

    #9747
    Anonymous
    Inactive

    I am having similar problem. I have a large World level map that I have drawn coasts for and a lot of rivers. I have the coasts drawn at a width of 5 and the rivers starting at 5 and going up to 20 or so sometimes. I am generating a Continent level that is 4 hexes for every 1 hex of the World level and it seems to be multiplying the width of all the shapes on the World level by 4. The coasts all have width 20 now and everything else seems to be multiplied by 4 also. On the new Continent level, all of the new width values from the World level are multiplied by 4, so the coasts are now all at width 80.

    I am using version 1.158 1.80_181. The world was originally made on version 1.157.

    #9748
    Anonymous
    Inactive

    The same thing is happening if I generate a new World and auto generate coasts and rivers and then create a Continent level off of that. The width of the shapes on the World level get multiplied by the number of hexes the new level is created at…

    #9763
    Joe
    Keymaster

    So I think what you’re describing is as designed, but you’re bringing up a good new use case.

    It is designed to scale all borders, rivers, roads, etc. to match the new view level. So if a line is 5% of a hex on the World map level, and you do a 6:1 ratio for the continent level, it will be 30% of the width of a continent level hex. And if you do 6:1 again for a kingdom level hex, it will be 180% of the width of a kingdom hex.

    I’ve got a fix added that can go out in the next update to let you override that per shape so it doesn’t resize. But I’m wondering, is there a use case to make this 3 options–resize, don’t resize, or resize by 50%? Or maybe give you a percentage selector? So maybe the river you draw should enlarge, but not by the full 6:1 (or whatever ratio you have).

    #9767
    Anonymous
    Inactive

    I think it is appropriate as you describe it. What it is actually doing when I create a Continent level from a World level is increasing the size on the World level by the amount it should only be increasing the size on the Continent level. It is also increasing the size on the Continent level, but based on the new width that the World level lines have been increased to. Hopefully these images work..

    Before

    After

    So the first link is the World level before creating the Continent level. Second link is after creating a 1:4 Continent level.

    • This reply was modified 10 months ago by . Reason: Links didn't work
    #9769
    Anonymous
    Inactive

    Here is the Continent level of the same area.

    Continent level

    #9770
    Joe
    Keymaster

    can you send the map file to support@inkwellideas.com. I’d really like to see what is going on in detail.

    #10611
    BusterBluth
    Participant

    Just curious if a fix for this problem was ever implemented? When creating a child map, my rivers are enormous! I’d rather they didn’t scale when going to the more detailed map. Since the rivers are tapered, I can’t get their width to shrink.

    #10615
    BusterBluth
    Participant

    I think I’ve got a workaround. When you tell the app to taper a line, I think it’s converting that line into a polygon shape.

    On your new child map, select the river and change the fill color to pink or some other bright, unnatural color. Then, trace a new river line over the original pink line, then taper if desired. Deselect your new river and select the original pink line. Then, delete the original.

    #10616
    Joe
    Keymaster

    Yes, when you taper a river it does convert it to a polygon.

    Going forward in the next update (in the next couple of days) we’ll have a feature where you can adjust the scaling of lines and polygon borders, but this won’t affect the overall size of the polygon, just the thickness of the borders. This will be a “scale factor” between map levels for each polygon%. Ex: if the line at the World level is about the width of a hex/tile, then when you have a continent level map that line would normally be about the width of 6 hexes (because there is a 1:6 ration between the world and continent levels). So if that scale factor is 50%, the line would be about 3 hexes wide on the continent level. And if the kingdom level was 4 hexes per hex in the continent map level, without the scale factor the line would be about 24 hexes across. But with that scale factor of 50%, it would be 6 hexes across (it was 3 hexes across on the continent level, and with a 4:1 ratio it would normally be 12 across, but with the 50% it is 6 hexes/tiles across instead.

    I think for anything more precise you’d have to make a new shape for the new level and then set the shapes to only display on the levels you want them at. 🙁

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.
Posted in

In Archive