Extreme Frustration in my first two hours

Home Forums Worldographer Extreme Frustration in my first two hours

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #10280
    Anonymous
    Inactive

    I’ve been working hard with Worldographer for the last two hours and I have been able to:

    1/ draw 3 roads
    2/ place two city features
    3/ place 4 labels

    The majority of the time was spent yelling at the totally unpredictable interface.

    Most of the time, it seems my mouse cursor is zipping around the screen, but in fact when I try to draw a line it starts the line where the mouse pointer was about tens seconds previously. The only way I can find to control this is to wait 10 seconds after the mouse has stopped moving and then try starting a line. Works about half the time.

    Zooming in with the mouse wheel is okay, but zooming out causes the map to slide all over sideways, up and down and then to disappear completely. Opening the mini map and fiddling around a bit seems to bring it back but it’s not possible to determine cause and effect.

    Is there a way to turn on a status bar of some sort so that I can see the status of my mouse pointer? IE is it mid operation, is an object selected, is it drawing something or placing something? Without any physical documentation, it’s impossible to tell what I’m doing half the time.

    Finally, can I change colours in the interface? I spent considerable time trying to find the near invisible scrollbar buttons.

    I know this program is setup much differently than lots of other mapping programs but I think I should have been able to accomplish more in two hours than what I noted above.

    Am I missing something fundamental in mindset on how to approach this program or am I just losing my mind?

    Thanks for listening.

    #10283
    Joe
    Keymaster

    I’m sorry to say I don’t have a good answer for the delay. There is no reason for a several second delay. I’ve only had one other person report an issue with a long delay between actions, and IIRC when I tried to get some details either I didn’t get a reply or didn’t get much useful info.

    The most important thing would be to know what computer type you’re using (windows, mac os, or linux, as well as some details of it win10 with 4GB of ram for example). And if using Windows, are you using our windows exe/native version or running it as a Java program.

    We’ve got hundreds (thousands?) of people using it each month, and as I’ve said I’ve only gotten 1 other report of something like this that I remember. On the other hand, if I were you I’d say, “this is the only program I have on my computer doing this.” So I hopefully understand.

    I think the other issues would be easier to figure out if this delay issue can be resolved. You can see our youtube videos which show how it should work. (In addition to seeing how to use many features, you’ll see that there is no delay as we draw maps.)

    #10354
    Anonymous
    Inactive

    Hi Joe,

    I posted something like the line issue quite a while ago. It seems like when you are trying to create many rivers or roads without changing the line tool the next river ( after deselecting the first one) places it’s first point someplace between where the end point from the first river was and where you are trying to start your new line. This isn’t consistant, but has happened over and over again. I did post screen shots way back when.. November 2018 post

    Shapes – Curve bug

    I am using the Windows native version on Windows 10.

    • This reply was modified 1 month, 3 weeks ago by .
    #10372
    Joe
    Keymaster

    Hmmm… I just tried this again and didn’t run into the issue. But I’m using the new 1.20 version (scroll down on the download page to get it) which had some reworking of the select/mouse click functionality. (It isn’t the official release yet because it uses a new build tool, and I’m still working out the mac version of that.)

    #10399
    Anonymous
    Inactive

    I’m also finding the shapes drawer almost non functional. No delay for me, but lines? hah!

    I do think it relates to the layers – they don’t seem to operate like you would think layers would. If I reorder the layers in the layer drawer, should they not reorder in the map? If I make all layers invisible, should there not just be grey featureless-ness? Really I just want a layer for physical bits (terrain, landscape etc.) and above it a layer for man made features (roads, cities, farms etc.) and above that a political layer (borders etc.) Maybe label layer. Anyway, layers that can be reordered, made visible, invisible, (and locked would be nice).

    And I also get mouse scroll wheel issues as described above. Meh. Fix shapes/layers first.

    Oh, Win10, Worldographer/Hexographer 2 v1.1095 platform 1.8.0_181

    Regards
    Tim

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.
Posted in

In Archive