Launch error

Home Forums Worldographer Launch error

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #10436
    demanche
    Participant

    I’m pretty certain this is more of a java issue, and may not be supported her but I’m giving it a shot anyway.

    Is anyone else having a problem with the v1.22 platform 14 java version launching and producing an error `Error: A JNI error has occurred…’
    When I run my previous v1.195 platform 1.8.0_261 java version, all is right with the world.

    When I load the “Windows Native” v1.22 this also seems to work successfully. This may sound a little picky but I prefer the java version as I can manually allocate the memory I need to load up my map (Yeah, it’s pretty big and detailed its at 400+MB .wxx file), so I set aside a good chunk of memory aside for it.

    Any enlightenment on this would be greatly appreciated and thanks in advance for any and all guidance.

    #10442
    Joe
    Keymaster

    We’ve moved up to Java 14, so you’ll need to update your JDK.

    We did set the source compliance level to 11 and I think set the binary to 11, so you can try 11 if you don’t want to go to 14.

    #10458
    demanche
    Participant

    The update worked perfectly, thank you again for your help. I am going to chalk this one up to, “I obviously missed the memo…”

    #10465
    Joe
    Keymaster

    Great! Honestly, I need to get the word out a bit more. I just updated the Download page to note we’re on 14.

    #10508
    tacoga
    Participant

    I am pretty sure that it is not your program, but I can not commit to purchase your product until i fix this.
    I have a:
    Asus 2.70Ghz i7-7500cpu x64 based processor 16gb ram 1tb hd
    Windows 10 pro V.1903 OS build 18362.1082
    Nvidia Gefoce gtx 950M graphics card.
    size of text and apps set at 250%
    Resolution set at 3840×2160
    but when your cityographer is installed and first opens up it and the writing opens up so small I can not read it even though it looks really clear but so small that I would have to have a magnifying glass to read it. like this print is 12 pitch what shows up is like a one. also it is NOT only your program but online and off line games and sub window programs, like when a program opens a window, the window that the program opens is the part the opens up micro size.

    your program seams like the program I need and would like to purchase. but I can not unless I get this fixed. I even have formatted my computer and reinstalled windows and all programs.

    #10511
    Joe
    Keymaster

    So Cityographer (which is a different, older program than what this particular subforum is dedicated to) uses an older user interface technology. You can launch it using Microsoft’s compatibility mode to improve the legibility of text. Here’s more info: https://support.microsoft.com/en-gb/help/15078/windows-10-make-older-apps-or-programs-compatible

    HOWEVER, all the Cityographer functionality has now been integrated into Worldographer, which uses a more recent UI library. You can download and install it from worldographer.com’s download page. To start a new settlement (city/village) map, go to the File menu in Worldographer and look for the “New City/Town/Village Map” option. The website has more instructions.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.
Posted in

In Archive