Worldographer won't launch with OpenJDK

Home Forums Worldographer Worldographer won't launch with OpenJDK

Tagged: ,

This topic contains 4 replies, has 4 voices, and was last updated by  PurpleGuitar 1 week, 1 day ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #9465

    Netzilla
    Participant

    Since Oracle will no longer supporting OracleJDK for free, I’ve been switching over to OpenJDK. However, for some reason Worldographer doesn’t launch when I run it using OpenJDK 1.8 (though Hexographer will).

    Error:
    ######:~/worldographer$ java -jar worldographer.jar
    Error: Could not find or load main class com.inkwellideas.ographer.ui.Worldographer

    Java:
    ######:~/worldographer$ java -version
    openjdk version “1.8.0_222″
    OpenJDK Runtime Environment (Zulu 8.40.0.25-CA-linux64) (build 1.8.0_222-b10)
    OpenJDK 64-Bit Server VM (Zulu 8.40.0.25-CA-linux64) (build 25.222-b10, mixed mode)

    I do have OpenJFX installed:
    ######:~/worldographer$ apt list openjfx
    Listing… Done
    openjfx/xenial,now 8u60-b27-4 amd64 [installed]

    OS:
    ######:~/worldographer$ cat /etc/os-release
    NAME=”Ubuntu”
    VERSION=”16.04.6 LTS (Xenial Xerus)”
    ID=ubuntu
    ID_LIKE=debian
    PRETTY_NAME=”Ubuntu 16.04.6 LTS”
    VERSION_ID=”16.04″
    HOME_URL=”http://www.ubuntu.com/”
    SUPPORT_URL=”http://help.ubuntu.com/”
    BUG_REPORT_URL=”http://bugs.launchpad.net/ubuntu/”
    VERSION_CODENAME=xenial
    UBUNTU_CODENAME=xenial

    Kernal:
    ######:~/worldographer$ uname -r
    4.15.0-55-generic

    #9505

    Joe
    Keymaster

    I was on vacation when this was posted, and I’m sorry I missed it until now.

    This is mostly likely caused by the split of Java removing Javafx after Java 8. I’m hoping to include the javafx jars in the next update of Worldographer so we can move past Java 8. You can install Java 8, or I can send you a command line for how to include the needed jars (I don’t want to post it here because it is very long with lots of paths and needs to be customized.) Please email support at inkwellideas dot com if you want it now.

    #9896

    aspiring grognard
    Participant

    Sorry to necro the thread, but this shows in search results when searching for “Error: Could not find or load main class com.inkwellideas.ographer.ui.Worldographer” so I thought I would chime in with the incantation that worked for me. I had to do a little fiddling from the instructions on http://worldographer.com/download/

    This is on Debian buster with AdoptOpenJDK-11 and OpenJFX installed from repos. Paths to openjfx libs and jars may differ depending on your install (find e.g. javafx.*.jar for what is probably the right path).

    java --module-path /usr/share/openjfx/lib/ --add-modules=javafx.controls,javafx.fxml,javafx.web -XX:MaxRAMPercentage=70 -Dprism.maxvram=2G --add-exports=javafx.controls/com.sun.javafx.scene.control=ALL-UNNAMED -Dfile.encoding=UTF-8 -classpath /usr/share/openjfx/lib/javafx.base.jar:/usr/share/openjfx/lib/javafx.controls.jar:/usr/share/openjfx/lib/javafx.fxml.jar:/usr/share/openjfx/lib/javafx.graphics.jar:/usr/share/openjfx/lib/javafx.media.jar:/usr/share/openjfx/lib/javafx.swing.jar:/usr/share/openjfx/lib/javafx.web.jar -jar <path-to>/worldographer.jar

    Thanks and cheers

    #9919

    Joe
    Keymaster

    Thank you! I’m not able to test on linux not I’m not much of a linux expert as well. Especially as it seems it can vary based on the distribution. 🙁

    #9924

    PurpleGuitar
    Participant

    Thank you, thank you, thank you! I’ve been trying to get Worldographer running under Linux but have had no luck. I’ve had to resort to booting back to Windows when I need to edit a map. 🙂

    Your solution worked perfectly under Ubuntu 19.04 — no edits necessary other than setting the path to worldographer.jar.

    Thank you again for taking the time to post your solution.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Posted in

Follow us on Twitter

See our YouTube videos

Support us on Patreon!
Get new icon sets each month and vote on icon set themes as well as upcoming Worldographer features.

Major Projects

Newsletter Subscription

If you want to subscribe to our monthly newsletter, please submit the form below.